Visual WebPart “Global Deployed” Fix!

Visual WebPart yapıp Visual Studio ortamında Deploy ettiğinizde kimi zaman Global Deployed olur ve WebPart ‘ınız Sayfada Add Webpart dediğinizde listeye gelmez. Bunun 2 nedeni olabilir.

Birincisi Feature ‘ınıza listelerinizi ve webpart ‘ınızı eklememiş olmanız (Normalde otomatik ekler, nadiren bu otomatik olmaz. yada bir sıkıntı olmuş olabilir.)

İkincisi ise Package ‘ın içinde, Feature ‘larınızı yada Webpart ‘larınızı eklememiş olmanızdır. (yine yukarıda feature ‘lar için belirtmiş olduğum sorunlardan olmuş olabilir.)

Fix ‘leyelim o halde bu durumu!

Sorun aşağıda gördüğünüz gibidir.  Global Deployed.

1

 

Öncelikle Solution Explorer penceresinde Feature klasörü içinde bulunan Feature ‘larımızı kontrol ediyoruz. Ardında Package Klasörünü kontrol ediyoruz.

0

 

Feature ‘ın/ların içinde liste ‘lerimizi ve Webpart ‘larımızı kontrol ediyoruz. Eğer eklenmesi gereken varsa ekliyoruz.

2

 

Feature ‘a/lara eklememiz gerekenleri ekliyoruz, projede kullandığımız. (Site Column, WebPart, Lists vs.)

4

 

Package ‘a Webpart ‘ları ve Feature ‘larımızı ekliyoruz.

2.5

 

Yukarıdaki işlemleri yaptıktan sonra tekrar deploy ediyoruz ve sorun düzelmiş oluyor. Webpart ‘ınızı sayfaya ekleyebilirsiniz.

Deploy işleminden sonra aşağıdaki gibi bir görüntü alacaksınız. Sorunumuz Fix ‘lenmiş oldu (:

5

 

Sorunsuz geliştirmeli günler (:

erdemtuzen

Project Manager at Nuevo SoftwareHouse
I am a Microsoft Certified Trainer (MCT).

and...

#Software #Solution #Sharepoint #SharepointOnline #WebApplication #EnterpriceApplication #Azure #ArtificialIntelligence #GameDevelopment #Entrepreneurial #NoviceNeyPlayer #AmateurPhotographer #BigUncle

Comments

comments

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

Time limit is exhausted. Please reload CAPTCHA.